check out my new blog at gmarik.info/blog

Wednesday, April 30, 2008

DataMapper: installing do_mysql on Ubuntu 8.04

Usually I had gems installed flawlessly.

But this time i wasn't so lucky with do_mysql.

I got this:

$ sudo gem install do_mysql --no-ri --no-rdoc
Building native extensions. This could take a while...
ERROR: Error installing do_mysql:
ERROR: Failed to build gem native extension.

/usr/local/bin/ruby extconf.rb install do_mysql --no-ri --no-rdoc
checking for mysql_query() in -lmysqlclient... no
checking for main() in -lm... no
checking for mysql_query() in -lmysqlclient... no
checking for main() in -lz... no
checking for mysql_query() in -lmysqlclient... no
checking for main() in -lsocket... no
checking for mysql_query() in -lmysqlclient... no
checking for main() in -lnsl... no
checking for mysql_query() in -lmysqlclient... no
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.


Little extra configuration solved the issue

$ sudo gem install do_mysql --no-ri --no-rdoc -- --with-mysql-lib=/usr/lib/mysql/

Now i can play with DataMapper eventually :)

0 Comments:

Post a Comment

<< Home